PDA

View Full Version : Cold air intake for 204



jimhemsath
11-22-2018, 01:41 PM
Hello all,

I'm new to this and I have a new to me 2004 XLR base with 30k miles. I want to add a cold air intake but all that I see are for 2005 and up. Is there something different about the configuration of the 2004 vs. the remaining years? If so has anyone else found an intake for the 2004?

Thanks all and Happy Thanksgiving!

Jim

JW7
11-24-2018, 08:37 AM
There have been many threads written about Cold air intakes on these babies and a search will get you to them..Seems to be a mixed success rate after installation....some enthusiasts had success..others like myself, unfortunately, did not..Truthfully, not sure as to why the variables exist..
I installed a Volent Cold air filter on my 2007 Base....ride was very good...felt a positive difference in the pickup......no rough idle or start up issues.... just kept throwing off lean air mix engine codes. I would clear the codes, then after about 20 miles...the CEL would come on again...
Some thought as to driving for awhile and letting the onboard computer reset itself , but that was not the case..
Tried everything to make it work ..uninstalled then reinstalled professionally ..changed the MAS ...rebooted the car to clear old codes..smoke test to make sure not leaking ..back and forth with Volent tech ..
Volents answer was that these units are not compatible after 07 model so they think that because my build date was so late in the year..Perhaps 08 parts were used..sounded crazy to me like they had no idea why not working and was looking for something.. They did refund my money...Would rather have been able to keep the unit on and working...
Hopefully..if you do an install..you will be one of the lucky ones ...good luck with it...check the threads...

long Tall Sally
11-24-2018, 11:35 PM
04 and 05 use all the same parts . the part number on the mass air flow ,filters, etc stock are the same so no reason it should not work. Volent told me they do not reccomend it unless the yhave actually installed a kit so they may have not found an 04 to put one on . As stated some 08s have a larger mass air flow and they do nto bolt up .

jimhemsath
11-27-2018, 04:19 PM
04 and 05 use all the same parts . the part number on the mass air flow ,filters, etc stock are the same so no reason it should not work. Volent told me they do not reccomend it unless the yhave actually installed a kit so they may have not found an 04 to put one on . As stated some 08s have a larger mass air flow and they do nto bolt up .

Thanks I'll give it a try.