Cadillac XLR Net - The ultimate online hub for Cadillac XLR owners and enthusiasts!
Supporting Membership - Supporting Vendors / Dealers - Advertise With Us

Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 9 of 9
  1. #1
    Junior Member
    Join Date
    May 2018
    Location
    Ohio
    Posts
    8
    Post Thanks / Like

    Cadillac XLR

    2005

    Default 05 does not have low gear

    Looking to help my dad with his 05 XLR. The car has only 14,000 miles on it. He picked it up a few years ago and only drives it a few times a year. When he went to get it out earlier this month it seemed like it was in high gear when he went to move it. We put a scanner on it and got a few codes. P0979 Shift Solenoid C circuit low & P0700 trans control system malfunction. Over the weekend we put in a new C circuit solenoid as well as fluid and filter change but the car still has no low gear. When on the rack in drive it seems to be in high gear as soon as you place it in drive. Any idea where to look next?

  2. #2
    Pit Crew
    Join Date
    Oct 2013
    Location
    HSV
    Posts
    212
    Post Thanks / Like

    Default

    Quote Originally Posted by quick66ss View Post
    Looking to help my dad with his 05 XLR. The car has only 14,000 miles on it. He picked it up a few years ago and only drives it a few times a year. When he went to get it out earlier this month it seemed like it was in high gear when he went to move it. We put a scanner on it and got a few codes. P0979 Shift Solenoid C circuit low & P0700 trans control system malfunction. Over the weekend we put in a new C circuit solenoid as well as fluid and filter change but the car still has no low gear. When on the rack in drive it seems to be in high gear as soon as you place it in drive. Any idea where to look next?
    Check the grounds.

  3. #3
    Junior Member
    Join Date
    May 2018
    Location
    Ohio
    Posts
    8
    Post Thanks / Like

    Cadillac XLR

    2005

    Default

    So the grounds haunt the XLR just like the CTSV. At least Caddilac kept it consistent

  4. #4
    Pit Crew harrower's Avatar
    Join Date
    Mar 2009
    Location
    canton,ohio
    Posts
    162
    Post Thanks / Like

    Cadillac XLR

    2006 infred red xlr-v

    Default

    How a bout your shift cable?
    2006 Infra Red XLR-V
    2005 Mag Red Corvette Coupe
    2006 DTS
    2008 SRX 4 NStar

  5. #5
    Junior Member
    Join Date
    May 2018
    Location
    Ohio
    Posts
    8
    Post Thanks / Like

    Cadillac XLR

    2005

    Default

    Shift cable? I guess I figured if it got the car from park to reverse to neutral and then drive all was good.

  6. #6
    05 does not have low gear rexster314's Avatar
    Join Date
    Oct 2015
    Location
    West Columbia, Texas
    Posts
    1,123
    Post Thanks / Like

    Cadillac XLR

    2006 Base Infrared

    Default

    Quote Originally Posted by quick66ss View Post
    Shift cable? I guess I figured if it got the car from park to reverse to neutral and then drive all was good.
    I don't think it's your shift cable. By you being able to select P, N, D, indicates the cable is good. Have you tried putting it in the "manual" mode and going through the gears?

  7. #7
    Junior Member
    Join Date
    May 2018
    Location
    Ohio
    Posts
    8
    Post Thanks / Like

    Cadillac XLR

    2005

    Default

    No go on the manual mode. When you put it in drive it feels like its in high gear. We put it on the rack and ran it and it feels like it shifts between the higher gears but does not down shift or start out in the low gears. We are going to replace the battery and check the grounds this weekend.

  8. #8
    Junior Member
    Join Date
    May 2018
    Location
    Ohio
    Posts
    8
    Post Thanks / Like

    Cadillac XLR

    2005

    Default

    Update - We replaced the solenoid C as well as the battery and checked the grounds. When the car is cold it has all the gears and drives normal. As soon as it warms up it wants to start out in high gear. With only 14,000 miles on the car we are now looking at what to do next... Any thoughts?

  9. #9
    Member
    Join Date
    Dec 2017
    Location
    AZ
    Posts
    50
    Post Thanks / Like

    Cadillac XLR

    2006 XLR Light Platinum

    Default

    Did you scrub the ground terminals and area where they attach with stainless brush or sand paper and use dialectic grease on them? Check the PCM connections also.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Cadillac, XLR and XLR-V are registered trademark of the General Motors Corporation & Cadillac Motor Division.  Neither Cadillac Motor Division nor any subsidiaries of GM© shall bear any responsibility for XLR-Net.com content, comments, or advertising. XLR-Net.com is independent from GM© and is not affiliated with, sponsored or supported by GM©.  Copyright/trademark/sales mark infringements are not intended, or implied.  All Rights Reserved