Welcome to the Cadillac XLR Forums!

Help using Tech 2

rheavn

Seasoned Member
Joined
Dec 3, 2019
Messages
102
Location
South Dakota
My XLR/V(s)
'09 Platinum #787
I get 2 DTCs on the "EBCM" How do I find what the codes are?

Learning how to use my Tech 2........................................................
 

Attachments

  • IMG_0442.JPG
    IMG_0442.JPG
    925.3 KB · Views: 18

rheavn

Seasoned Member
Joined
Dec 3, 2019
Messages
102
Location
South Dakota
My XLR/V(s)
'09 Platinum #787
Found the two codes on the EBCM. They are for the right front and right rear wheel speed sensors--C0040 & C0050. There was also a stored U2108 code, "Lost communication with EBCM" but on the last test it passed.
 

Attachments

  • IMG_0453.JPG
    IMG_0453.JPG
    474.4 KB · Views: 11
  • IMG_0454.JPG
    IMG_0454.JPG
    482.1 KB · Views: 12
  • IMG_0455.JPG
    IMG_0455.JPG
    921.1 KB · Views: 12

mickeytee

Seasoned Member
Joined
Apr 5, 2017
Messages
806
Location
North Atlanta
delete them and see if they come back. speed sensors can fail from debris blocking the signal and then they later work.
 

rheavn

Seasoned Member
Joined
Dec 3, 2019
Messages
102
Location
South Dakota
My XLR/V(s)
'09 Platinum #787
Those two DTCs will not delete and I continue to get the ABS & T/C light.
 

mickeytee

Seasoned Member
Joined
Apr 5, 2017
Messages
806
Location
North Atlanta
they may be faulty then. they of course are what has the traction light on. they are not expensive and not hard to replace.
 

rheavn

Seasoned Member
Joined
Dec 3, 2019
Messages
102
Location
South Dakota
My XLR/V(s)
'09 Platinum #787
Thanks for the reply! Is it the right side wheel sensors that may be bad? Any chance you have part numbers?
 

Cadillac XLR Forums

Not a member?  Join now!  It's Free!

Learn more about Supporting Membership

Supporting Vendors

Taput Tunning LLC

Top Hydraulics

Cadillac XLR Registry

Click here to enter the official Cadillac XLR and XLR-V Registry
Top Bottom