Welcome to the Cadillac XLR Forums!

Starting Issues

Blue Steel

Member
Joined
Feb 16, 2015
Messages
18
Location
Macomb, Michigan
My XLR/V(s)
2005 Blue Steel XLR .... 40,000 miles
Hello All,

I went to start the car to take one last ride and top off the fuel before storing for the Winter. I hit the start button and the car acted like the starter was hung up but would not fire. I thought maybe the battery was going bad and with the battery being from 2011 I thought I was due anyway. I changed the battery for a new one and was hopeful that might cure the starting issues. After installing the battery I still have the same problem, the car turns over but it sounds like the starter is hung up and it will not fire. If I hold the start button it will continue to try to fire but I don't want to do any damage by holding the start button. The car is always stored in the garage and always has a trickle charger on the battery when not on the road. Does anyone have any idea what I am looking at here. I was thinking there may be some type of fuel system module that went bad or maybe a fuel pump issue (hopefully not the latter as I'm sure that will be expensive). The car is a 2005 base model with roughly 40,000 miles on it. Thanks In Advance for any help on this as I am baffled as I've never had any issues with this car starting or running well previously.
 

Cadillac XLR Forums

Not a member?  Join now!  It's Free!

Learn more about Supporting Membership

Win a Cadillac CTS-V!

Cadillac CTS-V Dream Giveaway

Supporting Vendors

East Coast Used XLR Parts

Top Hydraulics

Cadillac XLR Registry

Click here to enter the official Cadillac XLR and XLR-V Registry
Top Bottom