Welcome to the Cadillac XLR Forums!

Top question

josua

Seasoned Member
Joined
Nov 13, 2016
Messages
96
Location
Gibsonia, Pa
My XLR/V(s)
2004 Raven Black xlr 2009 sts4
Have done top relearns couple of times. Everything works fine for a while, top working, trunk working. Then when putting the top up, it gets right to the part when the trunk closes and it stops. If I let go of the button on console and push it again the trunk closes. I can deal with this except now when I try to just open the trunk...nothing. Top up and down works except the trunk problem comes back. If I relearn the top everything works great for a while then the same thing happens. Rexter had said to write the counts down when its working ok, which I forgot to do. Seems to me that the count number isn't big enough? When this happens, there's no chimes when its done. Never did the count thing so I'm in the dark. Anybody?
 

05 GRAND DADDY

Seasoned Member
Joined
Jun 17, 2011
Messages
2,758
Location
South Central PA (Littlestown)
My XLR/V(s)
2005 Light Platinium Silver XLR
Have done top relearns couple of times. Everything works fine for a while, top working, trunk working. Then when putting the top up, it gets right to the part when the trunk closes and it stops. If I let go of the button on console and push it again the trunk closes. I can deal with this except now when I try to just open the trunk...nothing. Top up and down works except the trunk problem comes back. If I relearn the top everything works great for a while then the same thing happens. Rexter had said to write the counts down when its working ok, which I forgot to do. Seems to me that the count number isn't big enough? When this happens, there's no chimes when its done. Never did the count thing so I'm in the dark. Anybody?

I been dealing with the trunk, not closing at the end of cycle too. But never had the trunk problem you are describing. Just had my to the dealer for other things and of course the top works perfectly for them, got it back last week and been working fine for now! They had to change out the trunk latch for interior trunk lights stop working, it may of helped with trunk issues too, they said it’s all combined together in that unit[emoji849] Its even connected to emergency access key in the bumper... about $600 to repair... thank goodness the aftermarket warranty covered it!


Sent from my iPhone using Tapatalk
 

XLRATING

Seasoned Member
Joined
Jul 10, 2011
Messages
1,831
Location
Virginia
My XLR/V(s)
2006 Infrared XLR (Beauty); 2008 GT500 (Beast); 2007 Black XLR-V (Victor)
When that happened to us it was the tonneau sensor gone bad.
 

ccclarke

Seasoned Member
Joined
Sep 17, 2008
Messages
1,034
Location
Uncanny Valley, New England
My XLR/V(s)
2013 Graphite Metallic XTS Platinum
Have done top relearns couple of times. Everything works fine for a while, top working, trunk working. Then when putting the top up, it gets right to the part when the trunk closes and it stops. If I let go of the button on console and push it again the trunk closes. I can deal with this except now when I try to just open the trunk...nothing. Top up and down works except the trunk problem comes back. If I relearn the top everything works great for a while then the same thing happens. Rexter had said to write the counts down when its working ok, which I forgot to do. Seems to me that the count number isn't big enough? When this happens, there's no chimes when its done. Never did the count thing so I'm in the dark. Anybody?

Rear Tonneau sensor is a likely culprit, since it's the last component to operate before the Rear Decklid closes during a Folding Top Close operation.

Recommend performing another Re-learn and recording all sensor/switch values during a Folding Top Open/Close operation. The next time there's an issue, the out-of-tolerance value (usually a sensor) will be much easier to pinpoint for replacement. Knowing the nominal values when the Folding Top is operating correctly is the key to diagnosing problems when it doesn't.

CCC
 

josua

Seasoned Member
Joined
Nov 13, 2016
Messages
96
Location
Gibsonia, Pa
My XLR/V(s)
2004 Raven Black xlr 2009 sts4
I haven't tried anything with the scanner except relearn. The tonneau is the panel right behind the seats, correct? Do you know where that sensor is? I haven't got into this as much as you, afraid to really screw things up. And if I read right, it's a matter of changing that sensor? Dumb question, are they available?
 

josua

Seasoned Member
Joined
Nov 13, 2016
Messages
96
Location
Gibsonia, Pa
My XLR/V(s)
2004 Raven Black xlr 2009 sts4
Almost forgot, If that is the problem, is it adjustable or does it only go on one way? BTW, if it wasn't for guys like you, guys like me would have a lot less money. Appreciate it.
 

XLRATING

Seasoned Member
Joined
Jul 10, 2011
Messages
1,831
Location
Virginia
My XLR/V(s)
2006 Infrared XLR (Beauty); 2008 GT500 (Beast); 2007 Black XLR-V (Victor)
From a quick skim this thread looks like it will give you info on sensor locations: Trunk Inoperative Using Trunk Button It also goes through symptoms associated with different sensor failures, see the posts by ccclarke.

As to whether they’re still available, I have no clue. Check gmpartsdirect etc.
 

ccclarke

Seasoned Member
Joined
Sep 17, 2008
Messages
1,034
Location
Uncanny Valley, New England
My XLR/V(s)
2013 Graphite Metallic XTS Platinum
I haven't tried anything with the scanner except relearn. The tonneau is the panel right behind the seats, correct? Do you know where that sensor is? I haven't got into this as much as you, afraid to really screw things up. And if I read right, it's a matter of changing that sensor? Dumb question, are they available?

Sensors are available.

Front Tonneau is directly behind the seats, Rear Tonneau (aka Rear Closeout Panel) is forward of the Rear Decklid.
 

Cadillac XLR Forums

Not a member?  Join now!  It's Free!

Learn more about Supporting Membership

Supporting Vendors

Taput Tunning LLC

Top Hydraulics

Cadillac XLR Registry

Click here to enter the official Cadillac XLR and XLR-V Registry
Top Bottom