Welcome to the Cadillac XLR Forums!

P0023 - 24 Codes

Bigchip

New Member
Joined
Jul 21, 2022
Messages
4
Location
New Jersey
My XLR/V(s)
2009 XLR Platinum Crimson Pearl
Hi everyone, new to the forum.
My 2009 XLR keeps throwing codes P0023 and P0024.
Changed the oil and replaced the solenoids. Codes cleared but the returned a few days later.
Any ideas?
thanks
 

richardyoo

Seasoned Member
Joined
Jan 1, 2009
Messages
346
Location
Houston, TX
My XLR/V(s)
2006 Silver XLR-V
Could be the cam sensors.... I would also check all the connections... and sometimes it could be a grounding problem which is a common problem with corrosion prone areas where it snows. may take quite a bit of work to track down.
 

mickeytee

Seasoned Member
Joined
Apr 5, 2017
Messages
947
Location
North Atlanta
Did you spray the wiring plug to the solenoids really well? Some say oil can run all the way to the harness plug. Did you use an alignment tool to center the new magnets? The electric plugs could be brittle and not making could contact
 

Bigchip

New Member
Joined
Jul 21, 2022
Messages
4
Location
New Jersey
My XLR/V(s)
2009 XLR Platinum Crimson Pearl
I did use an alignment tool as per manual. Cleaned the plugs but I will clean them again and see what happens. (Cleared the code and it hasn’t come back.)
Thanks for the reply.
 
Last edited:

Cadillac XLR Forums

Not a member?  Join now!  It's Free!

Learn more about Supporting Membership

Supporting Vendors

Taput Tunning LLC

Top Hydraulics

Cadillac XLR Registry

Click here to enter the official Cadillac XLR and XLR-V Registry
Top Bottom