Welcome to the Cadillac XLR Forums!
  • The Cadillac XLR Net is now on instagram! Follow Us!

Help! Engine shut off while driving

05 GRAND DADDY

Seasoned Member
Joined
Jun 17, 2011
Messages
2,757
Location
South Central PA (Littlestown)
My XLR/V(s)
2005 Light Platinium Silver XLR
HAS ANYONE HAD THIS ISSUE AND KNOW WHAT FIXED IT?
About 6 weeks ago I was traveling home from a car show, while in the hot rod mood I was using the tap shifter option, I was almost home and coming down the hill to turn back our road, when the engine just up and shut off while driving, I got off the road and stop, then tried to restart it and it just turned over, i waited a few minutes it fired back up and ran fine! So after that, I drove it to shop and they said the only thing that they could find was all in the history , but no new codes. They check battery and it was weak so we replaced it ! A week later we drove the car to Oceans City and back, about 4 hrs each way plus cruising around while there. I went out on few other trips to local area and it was fine, but I didn’t use the tap shift option until again today heading to a car show ( I guess you could say I was curious) and again it shut off..... lucky, right before the car show, so drifted into parking area, right out front. Did the same thing tried to restart, cranked but would not start, so walked around at the show and hour and half later jump in and fired right up! It ran perfect all the way home about 20 minutes! Kind of weird but kind of scary too! Any ideas or information would be well appreciated! Thx Dan


Sent from my iPhone using Tapatalk
 

long Tall Sally

Seasoned Member
Joined
Sep 11, 2018
Messages
891
Location
Aiken SC
My XLR/V(s)
2008 xlr dove gray
another poster already has a thread going with what seems liek the same problem .check it out for suggestions that have not fixed his so far but may repair yours
 

05 GRAND DADDY

Seasoned Member
Joined
Jun 17, 2011
Messages
2,757
Location
South Central PA (Littlestown)
My XLR/V(s)
2005 Light Platinium Silver XLR
another poster already has a thread going with what seems liek the same problem .check it out for suggestions that have not fixed his so far but may repair yours

Yes! They quoted.. they Changed the battery, and never had a problem after that! But I did too, but It didn’t fix the problem.


Sent from my iPhone using Tapatalk
 
Last edited:

05 GRAND DADDY

Seasoned Member
Joined
Jun 17, 2011
Messages
2,757
Location
South Central PA (Littlestown)
My XLR/V(s)
2005 Light Platinium Silver XLR

IAN

Seasoned Member
Joined
Feb 19, 2015
Messages
496
Location
Province of Québec
My XLR/V(s)
2004 silver XLR
Hi Dan

Its a good thing that you visited a ''shop '' that confirmed that your xlr is having intermittent engine stop.
Would a Cadillac dealer with the latest data would have done better…... we dont know that.

The'' shop'' tool indicate no defective codes, either on fuel system components, engine module, the ignition system and its components or the grounds involves.

The engine stop like if you would have cut the power and later it would start with no problems and the engine runs smoothly….. as per you affirmations.

My suggestion ( only )….. would be that the anti theft system could be the one that could cause the interruption of the engine, that system is integrated in all the aspects of the car and if the module is infected, that module is capable to cut the ignition and the fuel of the car.

When you had the car rest for a while the car computer had maybe the chance to reload the system and had the car back to the running level.

I believe that we will have the similar situations in the increasing trend for the coming years, our cars are getting old and time makes its way.

Hoping that you will find the cause.

IAN




.
 

05 GRAND DADDY

Seasoned Member
Joined
Jun 17, 2011
Messages
2,757
Location
South Central PA (Littlestown)
My XLR/V(s)
2005 Light Platinium Silver XLR
Hi Dan

Its a good thing that you visited a ''shop '' that confirmed that your xlr is having intermittent engine stop.
Would a Cadillac dealer with the latest data would have done better…... we dont know that.

The'' shop'' tool indicate no defective codes, either on fuel system components, engine module, the ignition system and its components or the grounds involves.

The engine stop like if you would have cut the power and later it would start with no problems and the engine runs smoothly….. as per you affirmations.

My suggestion ( only )….. would be that the anti theft system could be the one that could cause the interruption of the engine, that system is integrated in all the aspects of the car and if the module is infected, that module is capable to cut the ignition and the fuel of the car.

When you had the car rest for a while the car computer had maybe the chance to reload the system and had the car back to the running level.

I believe that we will have the similar situations in the increasing trend for the coming years, our cars are getting old and time makes its way.

Hoping that you will find the cause.

IAN




.

Thx Ian
The first time it happened, it was less time to restart probably with in 5 minutes! I love this car, but at 104$ an hour, to keep trying to diagnose this problem just can’t happen, I’d rather it would break and not restart, I can’t afford this game of who knows plus it’s a very dangerous problem on the highway! At this point I’m not sure of my next move!


Sent from my iPhone using Tapatalk
 

IAN

Seasoned Member
Joined
Feb 19, 2015
Messages
496
Location
Province of Québec
My XLR/V(s)
2004 silver XLR
HI DAN.

Hi understand you so much as we had the same experience few weeks ago.

My Cadillac dealer knows that there is a needle in a haystack, however he do not knows were it is, had the car for 2 weeks and they could not figure out the problem. they suspect the anti theft module….. that its all.

My car runs great presently ( its warm weather ) but i am driving with the fear that the engine could stop at any time.

I still believe that the XLR is a great car and needs more and more cares.

Good luck

IAN
 

xlrlist01

Seasoned Member
Joined
Oct 31, 2013
Messages
252
Location
HSV
HI DAN.

Hi understand you so much as we had the same experience few weeks ago.

My Cadillac dealer knows that there is a needle in a haystack, however he do not knows were it is, had the car for 2 weeks and they could not figure out the problem. they suspect the anti theft module….. that its all.

My car runs great presently ( its warm weather ) but i am driving with the fear that the engine could stop at any time.

I still believe that the XLR is a great car and needs more and more cares.

Good luck

IAN

My understanding is that the anti-theft module will not stop a running engine, it will prevent it from restarting. My finger of suspicion is fuel rail pressure.
 

gulflyer

Active Member
Joined
Nov 12, 2011
Messages
32
Location
Fort Walton Beach, FL
My XLR/V(s)
2007 XLR-V
I've had a similar issue with my '07 XLR-V ( engine quits intermittently). I still haven't pinpointed the problem although the issue hasn't reoccurred in the last 5 weeks or so. What i have done is purchase a blue-tooth scanner (BlueDriver) that I've plugged into my ODB-2 port under the dash. Data is logged on my iphone while I drive. Hopefully if the problem surfaces again I'll be able to see what caused it.
 

05 GRAND DADDY

Seasoned Member
Joined
Jun 17, 2011
Messages
2,757
Location
South Central PA (Littlestown)
My XLR/V(s)
2005 Light Platinium Silver XLR
Latest update: we ordered a ECM Engine Control Module which came in today and they installed it , just went and picked up the car, and drove towards home about 10 miles and noticed the engine light was on! Turned around and drove it right back, and dropped it back off! Left a message I guess it will be Monday until they look at it again [emoji849]


Sent from my iPhone using Tapatalk
 

IAN

Seasoned Member
Joined
Feb 19, 2015
Messages
496
Location
Province of Québec
My XLR/V(s)
2004 silver XLR
Hi xlrlist

That is what a theft system is made for, if the XLR fuel system is defective a code should come up is in it.

The XLR theft module system gets its power direct from the battery and supply the ignition mode switch, also the instrument center security data is also link in the same module .

The doors and rear tail gate antennas are also link to this module.
The Locks, the latchs and doors modules are also link to the theft module system.
The fuel system ( door ) is also link…...that makes many suspects.

If the theft module gets infected no one can predict the proper functions of it, my dealer is suspecting it on my car despite with their up date scanner and technictians no defect code are available.

I guest that our XLR are getting in age and the components of the car.

Presently the XLR is running great ………

IAN
 

05 GRAND DADDY

Seasoned Member
Joined
Jun 17, 2011
Messages
2,757
Location
South Central PA (Littlestown)
My XLR/V(s)
2005 Light Platinium Silver XLR
Well another waste
of $900 of trying the new ECM! Got Roxy’s back yesterday, drove home about 25 minutes, parked in front of garage to let her cool down, before putting her in the garage to clean her up and about an hour later went and started her up. Once again sound like it was running on 1 cylinder, when trying to give it more gas it doesn’t even recognize the petal I floored it and didn’t change how the engine was running. So now I learned that I should purchase a fuel pressure gauge and when this happens, check the pressure, even tape it to windshield. Question can some shoot a picture of which connected this fuel gauge hose connects to and a location! Thanks Dan


Sent from my iPhone using Tapatalk
 
Last edited:

05 GRAND DADDY

Seasoned Member
Joined
Jun 17, 2011
Messages
2,757
Location
South Central PA (Littlestown)
My XLR/V(s)
2005 Light Platinium Silver XLR
NEW UPDATE: Word to the wise for XLR Owners If your ride is just shutting down while Cruz’in or starts up and sounds like it’s barely running on 1 cylinder, [emoji849] it very well maybe like mine was! And yes, a little while after the shut down it will start back up and run fine like nothings was wrong! The ground wire to fuel module maybe not be grounded as should be at the frame connection and could be causing this! VERY “CHEAP FIX” if you can fix it yourself ! You will need a short piece of #12 wire to reach the frame from the ground wire at the connector area , drill a hole in the frame and grind to bare metal at hole, use a heavy duty self tapping screw to attach new ground wire to frame! The fix is behind the rear drivers side wheel, remove rear wheel and inner plastic cover and look towards rear seat side for top 4 wire connector (see pictures) don’t cut but skin to wire and wrap and splice, then solder the new wire to bottom black wire and attach to frame! WHALA!! It fixed my 2005 for about 4 weeks now and it’s been running fine![emoji6] DON’T GROUND THE TOP GREY WIRE, like I did ITS A THE ⚡️HOT⚡️ WIRE[emoji20] and will blow the fuseThis was after dealership 1000$ bill for a new EMC[emoji849] which didn’t work!!!
Hope this helps anyone with this problem! It’s sucks when our baby’s don’t run, but it sucks even more when the is so simple and cost damn nothing but could cost thousands and nickel and dime us![emoji6]




Sent from my iPhone using Tapatalk
 
Last edited:

xlr&ls1

Active Member
Joined
Mar 9, 2013
Messages
42
Location
houston
My XLR/V(s)
2004 xlr
hi GRANDDADDY i had my 04 xlr for 7 years now i think, and its not a daily driver. i just turn it on after 4 months,wash it and test drive it ,getting it ready to take it to state inspection next week. and after all this years never experience this engine shuts off while driving until today.after searching the forums some ppl have fix it by changing the ecm and there is another thread where n2deep ground the fuel ground but on the passenger and you did it on the driver .
my question will be .is there two grounds i need to be looking for.
and have you had any more issues?
 

05 GRAND DADDY

Seasoned Member
Joined
Jun 17, 2011
Messages
2,757
Location
South Central PA (Littlestown)
My XLR/V(s)
2005 Light Platinium Silver XLR
hi GRANDDADDY i had my 04 xlr for 7 years now i think, and its not a daily driver. i just turn it on after 4 months,wash it and test drive it ,getting it ready to take it to state inspection next week. and after all this years never experience this engine shuts off while driving until today.after searching the forums some ppl have fix it by changing the ecm and there is another thread where n2deep ground the fuel ground but on the passenger and you did it on the driver .
my question will be .is there two grounds i need to be looking for.
and have you had any more issues?

It’s only on the drivers side, scroll up to the link above yours an follow those directions, I did my 05 this past spring and no more issues since the repair, the EMC cost me a wasted $1100....definitely try this first!


Sent from my iPhone using Tapatalk
 

Cadillac XLR Forums

Not a member?  Join now!  It's Free!

Learn more about Supporting Membership

Win a Cadillac CTS-V!

Cadillac CTS-V Dream Giveaway

Supporting Vendors

East Coast Used XLR Parts

Top Hydraulics

Cadillac XLR Registry

Click here to enter the official Cadillac XLR and XLR-V Registry
Top Bottom