Welcome to the Cadillac XLR Forums!
  • The Cadillac XLR Net is now on instagram! Follow Us!

2 new fuel pumps and a new fpcm still wont start

Btorious

Member
Joined
Oct 11, 2020
Messages
8
Location
Lake havasu city az
My XLR/V(s)
2004 black
Man what a nightmare put new battery both fuel pumps and the limes that go from the tank to the crossover tubes and a used fuel pump control module car still has no pressure in the fuel rail have put over 10 gallons of super unleaded losing my mind have tech 2 puts out the codes p0230 and p0231 can put gas in intake will start but wont stay running PLEASE SOMEONE HELP!!!!! Losing my mind here......
 

pure zen

Seasoned Member
Joined
Mar 12, 2014
Messages
779
Location
AZ
My XLR/V(s)
2005 Crimson Pearl XLR
May I ask? Who did the labor putting in both fuel pumps, lines, and a used pump control module,,,,

you or a shop?
 

redvett94

Seasoned Member
Joined
Dec 29, 2017
Messages
97
Location
AZ
My XLR/V(s)
2006 XLR Light Platinum
Have you checked the fuel pump module ground? It may be the problem. I think someone here had that problem a while ago do a search.
 

mickeytee

Seasoned Member
Joined
Apr 5, 2017
Messages
468
Location
North Atlanta
why did you put on a used control module ? was your old one bad? you most likely got another bad one. 04 and 05 had a lot of those go bad when newer
 

Z1.

Seasoned Member
Joined
Apr 11, 2013
Messages
154
Location
Fallbrook
My XLR/V(s)
2006 Raven Black XLR
Check your that your ECU isn't bad (maybe using another ECU) The ECU energizes the relay(s) that controls the fuel pumps.
 

Cadillac XLR Forums

Not a member?  Join now!  It's Free!

Learn more about Supporting Membership

Win a Cadillac CTS-V!

Cadillac CTS-V Dream Giveaway

Supporting Vendors

East Coast Used XLR Parts

Top Hydraulics

Cadillac XLR Registry

Click here to enter the official Cadillac XLR and XLR-V Registry
Top Bottom