Welcome to the Cadillac XLR Forums!
  • The Cadillac XLR Net is now on instagram! Follow Us!

I think I may have found it.

monepit

Seasoned Member
Joined
Dec 8, 2008
Messages
318
Location
Evansville Indiana
My XLR/V(s)
2004 black raven
Once again I went to put the top down and it stopped. So being thursday I drove straight to the caddy dealer. Dave, Who is the XLR tech, And a really good guy, Met me at the door and hooked the Tech 2 to it and ran the top. No codes. the tech 2 saw nothing wrong, but the top wouldnt move. He was bewildered. I told him this is what it has been doing since I got it. Then I said watch this. I grabbed the top and pushed it back and down into the trunk with my hands. He said, It shouldnt do that. I didn;t think so either. As I understand hydrolics you cant move them by hand. I told him I read on here that the pump has 5 valves that control the Hyd. circuits and if one of them sticks half way it would do that. He agreed. So He is going to get into it tomorrow. Alright, I know we have some pretty sharp people here, Does that make sence to you. I dont want to replace a high dollor pump unless that is it, but I have had enough of this. This is the coolest car I've ever owned and I would gladly do it if it will end this problem. The bad part is the Caddy dealer in Fl. replaced 2 pos. sensors and a top control module to the tune of $1300 in january and it still does the same thing. Any thoughts would be appreciated.
 

Cadillac Tech

Seasoned Member
Joined
Oct 16, 2008
Messages
3,843
Location
Cicero,Indiana
The folding top can be moved by hand even if the valve on the pump is closed. If you stop the top with the back window stright up and down (like trying to wash the back window), it can slowly slide into the trunk. The decklid has supports to help it stay open. So, no I don't think the pump is the problem. The third top postion sensor should have been replaced when the other two were replaced in FL.
 

monepit

Seasoned Member
Joined
Dec 8, 2008
Messages
318
Location
Evansville Indiana
My XLR/V(s)
2004 black raven
Thats good to hear. That pump is expensive. Whitch one is the 3rd. I know they replaced the one on the drivers side of the top. Also why do you think the tech didn't find anything wrong? Thanks for any help yu can give.
 

Cadillac Tech

Seasoned Member
Joined
Oct 16, 2008
Messages
3,843
Location
Cicero,Indiana
Thats good to hear. That pump is expensive. Whitch one is the 3rd. I know they replaced the one on the drivers side of the top. Also why do you think the tech didn't find anything wrong? Thanks for any help yu can give.

There is another one on the drivers side of the linkage for the decklid/trunk and on the linkage for the front tonneau. It is behind the closeout panel just behind the rear firewall inside the trunk/top storage area.
 

cubby558

Seasoned Member
Joined
Oct 17, 2008
Messages
2,752
Location
IL
My XLR/V(s)
'16 Z06, "06 XLR-V Infra Red-Sold, RII, RIII & RIV survivor, Mdwst Maurader
You are contridicting yourself in your earlier post you said "The bad part is the Caddy dealer in Fl. replaced 2 pos. sensors and a top control module to the tune of $1300 in january and it still does the same thing. Any thoughts would be appreciated." If you are unsure send Cadillac Tech your VIN and he can run a history on the car and find out what was done. <!-- / message -->

Hard to determine what they should be looking for if you keep changing the story. Hope they get it fixed for you. I guess it was too late for you to get the GMPP when you bought the car? It would have saved you thousands!!!

Thats the 3 that were replaced.
 

monepit

Seasoned Member
Joined
Dec 8, 2008
Messages
318
Location
Evansville Indiana
My XLR/V(s)
2004 black raven
Thanks for pointing that out. What happened is they originally diagnosed the sensor on the drivers side of the top. I watched them change it. They reprogrammed the top and tried it and it still didn't work. The called caddy engineering and they recommended changing the one for the little door behind the seat. The tech told me they didn't have any more sensors in stock and since apparently the one they replaced wasn't the problem it was the same sensor as the one on the door behind the seats so he used it to replace the one on the door behind the seats. That still didn't fix it so they kept the car and I left. While I was gone over the next 4 days they said they replaced the one on the trunk and the control module for the pump. They said that fixed it and I picked it up and the top worked fine. So all three were changed but 2 were new and one was moved from the top to the cover door. I drove home and I live in Indiana so the top didn't go down 5 times in the next 3 months. but it worked fine. When It finally got warm and I started using the top allot it stuck a few more times. The last 2 times it stuck I took it to the dealer and it started working again. I got in it Thursday after work and it wouldn't go down. So I drove straight to the dealer and Dave hooked the Tech 2 to it, no codes so they kept it. The had it today and 5 steps into his diagnosis it started working so he couldnt go any farther. I picked the car up, drove it home, put the top up and washed the car. When I went to put it down it stuck again. This time I played with it. The little door will go up, The trunk will open and the header will releace, thats where it stops. I can grab the top and freely push it into the trunk. But if you stop half way and hit the button a couple times it locks up and wont move. Whats funny is at that point if you open the bypass valve the top still wont move. even after ten minutes it still wont move. The onyy was to get it up is to keep hitting the button. It will move about an inch forward each time hit the button in either direction. when it gets to the header and you latch it it will continue the operation and close the little door and the trunk.
 

monepit

Seasoned Member
Joined
Dec 8, 2008
Messages
318
Location
Evansville Indiana
My XLR/V(s)
2004 black raven
Well after a week in the shop Trixie is home. Seems one of the position sensors they installed in Janurary was bad. The good news is it was covered under warrenty. I talked to Dave who told me every time I bring it in it works fine. I told hin take it to lunch or take it home and maybe it will do it for you. He took it to lunch put the top down and when he went to put it up it stuck. he drove it back with it stuck and put the tech 2 on it and took a snapshot. found the bad sensor and fixed it. They only paid him 7/10ths for the job so he got a good tip. We need more people like Dave.
 

Cadillac XLR Forums

Not a member?  Join now!  It's Free!

Learn more about Supporting Membership

Win a Cadillac CTS-V!

Cadillac CTS-V Dream Giveaway

Supporting Vendors

East Coast Used XLR Parts

Top Hydraulics

Cadillac XLR Registry

Click here to enter the official Cadillac XLR and XLR-V Registry
Top Bottom